Investigating issues with Alpha Bank (Greece)

Incident Report for nBanks

Investigating

We're investigating a consent renewal incident affecting Alpha Bank (Greece).
Early signs point to an incident with one of our external providers.
We'll share more as we confirm details.
Posted Jul 09, 2026 - 13:46 WEST
This incident affects: Financial Institutions (Authorization, Retrieve Data).