Issue with Open Banking Provider – SIBS

Incident Report for nBanks

Update

We are continuing to work on a fix for this issue.
Posted Dec 15, 2025 - 13:02 UTC

Identified

We have identified the issue with SIBS, which is currently affecting Retrieving Financial Information.

The issue appears to stem from Outage in SIBS.

We are awaiting updates from the provider and will share further information as it becomes available.

Kind regards,
nBanks Team.
Posted Dec 15, 2025 - 13:02 UTC
This incident affects: Financial Institutions - Retrieve Data and Financial Institutions - Access.