Fetch Account Information is Unstable – Millennium BCP, Portugal

Incident Report for nBanks

Monitoring

A fix has been implemented for the issue affecting Millennium BCP, Portugal.
We are currently monitoring the results to ensure the system is fully stable.

Kind regards,
nBanks Team.
Posted May 20, 2025 - 09:32 UTC

Identified

We have identified the cause of the issue impacting Millennium BCP, Portugal.
The issue is related to a non-communicated change on the Bank Institution's API.

We are coordinating with Millennium BCP to resolve the issue.

Kind regards,
nBanks Team.
Posted May 20, 2025 - 08:05 UTC

Investigating

We are currently investigating an issue affecting connectivity with Millennium BCP in Portugal. Users may experience delays or failures when attempting to retrieve financial data from this institution.

Our team is working to identify the root cause and will provide further updates as soon as possible.

Kind regards,
nBanks Team.
Posted May 20, 2025 - 07:48 UTC
This incident affects: Financial Institutions - Retrieve Data and Financial Institutions - Access.